Full postcodes don't seem to work in Dorset

  • Problem
  • Updated 3 years ago
  • In Progress
I have just tried to set some favourites of places to visit in Dorset in the UK and only the first 4 digits of the postcode work as follows:

DT2 7LG only DT2 7 is shown
DT3 4LA only DT3 4 is shown
DT3 4JG only DT3 4 is shown
BH20 5QS only BH20 5 is shown

The full postcodes all work in Google, IGO, TomTom and Sygic.

I do have the latest Android version 214 with the latest maps from around Christmas time.

Yet another bug in CoPilot or old/incomplete map data!
Photo of dickyboy

dickyboy

  • 147 Posts
  • 4 Reply Likes
  • frustrated

Posted 4 years ago

  • 3
Photo of Christian

Christian, Official Rep

  • 2633 Posts
  • 142 Reply Likes
I've just tested those postcodes with the latest version of CoPilot Live Premium (UK & Ireland maps)
DT2 7LG - shows Athelhampton Road
DT3 4JG - shows New Barn Road
DT3 4LA - doesn't show any roads, but tapping 'skip' shows a location on the coast, cross referenced, its the same location as Google Maps and its right next to a main road so the favourite will still work just fine.
BH20 5QS - doesn't show any roads, but tapping 'skip' shows a location, I cross referenced this with Google Maps and it shows it as The Lulworth Estate.

Did you get different results to what I posted above? Can you check to be certain you have latest maps (go to Settings > About CoPilot to see the date of the maps, it should have 3.2011 at the beginning).

UPDATE: The above test was with latest shipping iPhone version. I'm retesting on Android device now...
Photo of Christian

Christian, Official Rep

  • 2633 Posts
  • 142 Reply Likes
UPDATE 2: We're investigating this further.
Photo of steve pitkin

steve pitkin

  • 8 Posts
  • 2 Reply Likes
Just tested this on Android version 9.1.0.214 with UK and Ireland Map 7.2011.02.2.12.6.1.1 and the results are as follows:-
DT2 7LG does not exist but Althelhampton Road does as DT2 8
DT3 4JG does not exist but New Barn Road does as DT3 4
DT3 4LA does not resolve to a location only as DT3 4
BH20 5QS does not resolve to a location only as BH20 5
Please update the Android Map to the latest version as there are many map and speed limit errors
Photo of dickyboy

dickyboy

  • 147 Posts
  • 4 Reply Likes
I do not get the same results as you.

SW and Map on Android info as follows:
Version 9.1.0.214
Data: GRD_NT.EU-base 3.2011.02.2.14.6.1
uk and ireland CTY_NT.EU-UKand Ireland 7.2011.02.2.14.6.1.1

DT2 7LG just shows a list of postcodes all starting with DT2 7L and ending in A, B, D, E, F and S.

DT3 4JG shows a list of places, there are too many to add here but the first few are:
DT3 4 Weymouth, GB, Dorset
DT3 4 Abbotsbury, GB, Dorset
DT3 4 Winterbourne Abbas, GB Dorset
DT3 4 Upwey, GB, Dorset

and the last couple are:
DT3 4 East Bexington, GB, Dorset
DT3 4 Friar Waddon, GB, Dorset

DT3 4LA gives the same results as in the first example.

BH20 5QS shows a list of places, there are too many to add here but the first few are:
BH20 5 Wareham, GB, Dorset
BH20 5 Burngate, GB, Dorset
BH20 5 Langton Matravers, GB, Dorset
BH20 5 East Lulworth, GB, Dorset

and the last couple are:
BH20 5 Lulworth Camp, GB, Dorset
BH20 5 Kimmeridge, GB, Dorset

I don't have a skip button, so please test on Android. This is not very good, other satnavs sorted out post codes so that full 7 digit codes worked years ago.
Photo of David

David

  • 129 Posts
  • 16 Reply Likes
Can we have an update on this problem please.

Prompted by lack of complete postcode in Christchurch - BH23 1PZ which only gets to BH23 1 as Christchurch, GB, Dorset. Buildings have been there for many years.

Thank you.
Photo of Christian

Christian, Official Rep

  • 2633 Posts
  • 142 Reply Likes
We're looking to get a fix out for this soon. Sorry I don't have an exact date to share right now, as soon as I get more news I'll post an update here.
Photo of David

David

  • 129 Posts
  • 16 Reply Likes
Thanks Christian. The county of Dorset is one of the UKs major tourist areas and pretty soon it will once again be clogged with holiday makers trying to find their hotels/campsites etc.
Photo of David

David

  • 129 Posts
  • 16 Reply Likes
Hi, we are creaping towards 2 months since this issue was raised and are still awaiting a solution.

Can you tell me if there is an Android update due soon (to co-incide with the IPhone update mentioned here: (http://forum.copilotlive.com/copilotl...)

If so will this issues will be rectified in the update. I note the issue does not affect Iphone users so its I guess its down differences in the data files.

Clearly there are some large gaps in the map/postcode (Android) data files you are circulating and I don't think it unreasonable for users to expect this to have been amended over the afor mentioned period.

Regards, David.
Photo of Christian

Christian, Official Rep

  • 2633 Posts
  • 142 Reply Likes
Sorry for inconvenience caused. We're working on an update which has a number of fixes and improvements including improved post code support for iPhone/iPad.

If you have problem with post codes on Android please delete the map data and redownload - that should fix the issue.
Photo of David

David

  • 129 Posts
  • 16 Reply Likes
Thank you for the instruction - thats seems a pretty simple fix, and has rectified the problem on my "Android" installation. So thank you for that.

But I do wonder when exactly ALK were going to share the fix with its users ????
Photo of eezytiger

eezytiger

  • 179 Posts
  • 17 Reply Likes
I also discovered this problem on a trip to Dorset/Devon last week and I'm pleased to say that deleting and re-downloading the maps fixed the problem for me too.

I don't know whether the problem does/did exist for other locations, but what does this mean in the great scheme of things? In other words, should everyone be deleting and re-downloading the maps or would these be isolated cases?
Photo of steve pitkin

steve pitkin

  • 8 Posts
  • 2 Reply Likes
Is there a difference between upgrading and deleting first, I had previously just upgraded but have now deleted the map and downloaded and installed the map again.
If this is the case then the upgrade should delete the old map first.