26/01/12... Another useless update!

  • Problem
  • Updated 2 years ago
Well today's iPhone update of CoPilot Live has f*£k£d everything up again! All my downloaded maps are no longer recognised as I'm being asked to download them again, which isn't exactly a five minute job! I thought the whole point of the last upgrade was that once the maps were downloaded, you could update the software without re-downloading everything again!
The first time I ran the software, I downloaded the entire 1.4Gb European map, only to switch it on in Holland and find that no maps were present. Now the BeNeLux and UK maps have gone again thanks to this new update!

Tony

  • 2 Posts
  • 0 Likes
  • P*$$ed Off!

Posted 2 years ago

  • 1

Dave, Official Rep

  • 1519 Posts
  • 63 Likes
Hi Tony,

Sorry you're experiencing this problem. In our tests prior to launching the update it worked fine for us.

If you are unable to redownload the maps, quit CoPilot (double tap CoPilot icon, tap X on CoPilot Premium) then go to SETTINGS > COPILOT PREMIUM then turn FULL RESET to ON. Tap BACK then relaunch CoPilot and it will let you download the maps again.

We'll investigate and try to reproduce your problem as to why it erased your maps.

Tony

  • 2 Posts
  • 0 Likes
There was no problem downloading the maps again but the whole point is that I shouldn't have to! If I'm in Europe and there's a software update which then makes all my dowloaded maps disappear, I'm going to be without my GPS which I heavily rely on! Either that or sit in McDonalds for a day trying to re-download them on their slow free WiFi!